[技术求助] 想得到正负都有的正弦波

[复制链接]
357|27
 楼主 | 2019-8-17 19:02 | 显示全部楼层 ||阅读模式
DSP输出SPWM经过RC低通滤波得到的正弦波为正电压,想得到正负都有的正弦波

使用特权

评论回复
| 2019-8-17 19:04 | 显示全部楼层
请问楼上这个是为什么吗?我不是很懂啊

使用特权

评论回复
 楼主 | 2019-8-17 19:07 | 显示全部楼层
我拉了一个基准电压,基准电压也是通过DSP输出占空比一定频率一定的PWM再通过另一路RC低通滤波器得到的直流电压,电压值为正弦波幅值的一半,可是拿示波器正端接正弦波,公共端接基准电压,打出来的波形并没有负的电压出现

使用特权

评论回复
| 2019-8-17 19:12 | 显示全部楼层
万用表测基准电压变为0?

使用特权

评论回复
 楼主 | 2019-8-17 19:15 | 显示全部楼层
我该如何得到正负都有的正弦波?

使用特权

评论回复
| 2019-8-17 19:19 | 显示全部楼层
什么意思?不是很明白你说的什么,能再解释一下这个现象吗

使用特权

评论回复
 楼主 | 2019-8-17 19:21 | 显示全部楼层
我想得到能通过程序可调的直流电压做基准电压

使用特权

评论回复
| 2019-8-17 19:24 | 显示全部楼层
最简单的办法是通过电容输出。

使用特权

评论回复
 楼主 | 2019-8-17 19:27 | 显示全部楼层
或者我该如何简单地得到有正负的正弦波

使用特权

评论回复
| 2019-8-17 19:33 | 显示全部楼层
单电源带直流偏置的运放电路,放大正弦波,输出就是用电容去直流分量。

使用特权

评论回复
| 2019-8-17 19:37 | 显示全部楼层
无论正弦波的幅值如何变化)?

使用特权

评论回复
| 2019-8-17 19:40 | 显示全部楼层
发图看下。
并说明:
你示波器测试的哪里;
万用测试的哪里;

使用特权

评论回复
| 2019-8-17 19:43 | 显示全部楼层
是正弦波就行了, 其中的直流分量是参考点的选择的因素, 不用在意的.

使用特权

评论回复
 楼主 | 2019-8-17 19:46 | 显示全部楼层
没接示波器的时候用电压表测C2两端电压是恒定直流1.6V,正弦波幅值为3.2V,接上示波器后(公共端接基准电压,正极端接正弦波),C2两端的电压变为0了,这样示波器打出来的波形就没有负值。

使用特权

评论回复
| 2019-8-17 19:52 | 显示全部楼层


示波器的值不对,和你的示波器设置或者示波器内部电路、源的驱动能力有关吧;
    你可以,在输出接运放跟随,测试下

使用特权

评论回复
| 2019-8-17 19:55 | 显示全部楼层

万用表读数为0;
   正确的,作了平均值算法,当然是0

使用特权

评论回复
 楼主 | 2019-8-17 19:59 | 显示全部楼层
跟示波器的设置应该没关系,我用示波器正端接正弦波,公共端接DSP输出为恒定1.9V的引脚,示波器显示的正弦波有正负,正峰值1.3V,负峰值为-1.9V,和想象中完全一样。

使用特权

评论回复
 楼主 | 2019-8-17 20:01 | 显示全部楼层
    但是公共端接经过RC出来的直流电压1.6V,示波器显示的正弦波还是峰值3.2V,谷值0v。此时,用万用表测RC出来的1.6V端点与地之间的电压,就不再是原来的1.6V了,变为0V了。

使用特权

评论回复
| 2019-8-17 20:07 | 显示全部楼层

板子哪里被你弄坏了吧。
那说明电路本身设计没 ,示波器及设置也没问题。

使用特权

评论回复
| 2019-8-17 20:09 | 显示全部楼层

电路和示波器,你这样连起来后有问题。
和示波器连起来后,也要有个电流回路,才能测试到正负的正弦波;

使用特权

评论回复
扫描二维码,随时随地手机跟帖
您需要登录后才可以回帖 登录 | 注册

本版积分规则

我要发帖 投诉建议 创建版块 申请版主

快速回复

您需要登录后才可以回帖
登录 | 注册
高级模式

论坛热帖

在线客服 快速回复 返回顶部 返回列表